在安装vue-cli时候,使用的命令是npm install vue-cli -g

这是安装2.X版本的指令,而安装3.0版本及以上版本的指令是npm install @vue/cli -g

  1. 卸载3.0之前的版本.

    1
    2
    npm uninstall -g vue-cli
    yarn global remove vue-cli
  2. 卸载3.0之后的版本

    1
    2
    npm uninstall -g @vue/cli
    yarn global remove @vue/cli
1
2
3
4
5
   


3. 安装新版本的vue

npm install @vue-cli -g

1
2
3

如果不想安装最新版的vue,可以安装指定版本的vue

//安装2.9.6版本
npm install -g vue-cli@2.9.6
yarn global add vue-cli@2.9.6
//安装4.0.5版本
npm install -g @vue/cli@4.0.5
yarn global add @vue/cli@4.0.5

1
2